U2F not supported error

If you see the "U2F not supported" error, this means that your browser does not (properly) support the U2F protocol. This protocol is used by MyCrypto to connect with your hardware wallet.

To solve this issue, you can try using a different browser, such as Google Chrome. You can also use the MyCrypto Desktop application. If you are on Android and want to use your Ledger Wallet, you can try using the Ledger U2F Bridge app.





Need more help? Send an email to support@mycrypto.com with as much information as possible about your issue and we will get back to you shortly.

Please include screenshots, TX hashes, and what browser you are using. Thank you for your patience.